No Gutsy for me – yet

Five days to go, a release candidate is out and I felt like upgrading – then I noticed that bug #121653 (“fglrx breaks over suspend/resume”) is still open. I have a ThinkPad T60 with an ATI X1400 and I’m using the closed-source fglrx driver, so my setup is clearly affected by this bug.

As a solution I could switch to the free ATI driver, without 3D support, and with somehow degraded 2D performance. I don’t want that. Or I could just stop using Suspend-to-RAM. I don’t want that either. So either I wait until AMD fixed the driver, or I compile my own kernel with the SLAB allocator which is known to work with fglrx. I’m not sure whether the latter really is an option, it probably breaks other modules from the Ubuntu repositories, and I’m not keen on compiling every single piece myself. I’m running Ubuntu, not Gentoo. And the slogan “It Just Works” made me switch from Debian to Ubuntu…

Anyway, this shows once again how important open-source drivers are, and according to reports AMD is working already towards this direction. I will gladly install the open drivers once they are released.

Advertisements

One thought on “No Gutsy for me – yet

  1. Hosting Reviews

    Yeah, I’m waiting to upgrade until the final release myself. Also suspend/resume has never really worked right for me. I wish it would though because I would like to use ubuntu on my laptop, but there is no way that I’ll use it until I can suspend/resume.

    Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s